This project is read-only.

Required SDK Version?

Topics: Setup / Configuration
Jun 19, 2007 at 5:06 PM
I can't get setup to complete due to the Windows SDK requirement. I've got a full install of version 6.1.6000.16384, but the setup directs me to download the November 2006 release. Is there any way I can easily install DinnerNow without uninstalling the SDK and reinstalling the old release?

Thanks
Jul 28, 2007 at 6:47 PM
I have the same problem...any solution to it?
Aug 9, 2007 at 12:14 AM
The correct SDK is the Windows Vista SDK. It should however work with higher SDK's but the dependency checker is configured to scan for 6000.0.0.

workaround is to edit the configuration the dependency checker uses, its dc1.exe.config in the \dinnernow\bin folder. Look for

<dependency dependencyType="Software"
value="Microsoft Windows Software Development Kit (6000.0.0)"
enabled="true"
title="Microsoft Windows SDK for Windows Vista and .NET Framework 3.0 Runtime Components"
explination="DinnerNow Requires intallation of the SDK Tools"
downloadUrl="http://www.microsoft.com/downloads/details.aspx?FamilyId=C2B1E300-F358-4523-B479-F53D234CDCCF&displaylang=en"/>

then change or remove the entire dependency. Obviously make sure you install the SDK before proceeding

David