Why does this app require IIS7?

Jun 9, 2008 at 3:16 AM

I don't understand the important requirement for IIS7.. why is it required? A ton of developers still use Windows XP/Windows 2000/Windows 2003 which can use .NET 3.5. Why isn't there a version which works for IIS5 and 6?